読者です 読者をやめる 読者になる 読者になる

Mavericks(Mac OS X 10.9)にRuby1.8.7をインストールする方法

Ruby

今さら最新のMac OSRuby 1.8.7 をインストールする人は少ないかもしれませんが、もろもろの理由でRuby 1.8.7が必要なのでインストールしてみました。

特に新しい情報はありませんが、brew, rbenv を使ってインストールしました。

% brew install apple-gcc42
% CC=/usr/local/bin/gcc-4.2 RUBY_CONFIGURE_OPTS="--without-tcl --without-tk" rbenv install 1.8.7-p374
% rbenv shell 1.8.7-p374